Showing results for 
Search instead for 
Did you mean: 

Ifit error


Hello, the sessions of sports shared via Ifit are wrong, for a week the difference in altitude is no longer taken into account by Strava, example, my last two sessions I did 600 meters and 600 meters of elevation gain and my two sessions on Strava display zero meters.

(NordicTrack Commercial X32i treadmill workouts) 



Today's training syncs automatically with Strava (I am a Premium iFit subscriber and Strava) but still no elevation...

Very frustrating.


Same issue is discussed here:


Some change ob Stravas side must have happend from 20th to 21st July.

As I don't use an Ifit Premium membership only manual upload is possible for me (and most of the Users). Worked for hundreds of workouts before.

So far the Strava support team stopped replying on my support thread. Very frustrating.

Here's the last update I got from Strava Support:

Aug 9, 2023, 2:29 PM MDT

We are currently working with ifit to visualize elevation for manually uploaded activities while we work to correct the initial elevation issue with ifit activities. I don't have a firm timeline but it is currently being worked on.

Thanks for the update! Really hope it'll be fixed soon.


I found the reason on our side (Indoor Cycling Software) for the ignored GPS-data (latitude, longitude and elevation). If we set the element FIT_SUB_SPORT_INDOOR_CYCLING, Strava will ignore all GPS-data, even if the "Sport_Type=VirtualRide" is set. From our point of view this is an error on Strava side which has to be fixed. In meantime, we remove this element for virtual rides.


I have the same problem:

If I've upload an Indoor Cycling Activity with a FIT-File to Strava via API ( the route details (latitude/longitude/evelation) are not displayed afterwards.
If I've upload the same file manually via Strava-Website, everything is fine.
If I use the tcx-file instead of the fit-file during the API-Upload everything is fine.

What's wrong here with the API-FIT-File-Upload?

Mt. Kenya


I have the same issue. In addition when I upload my iFit training to Garmin Connect it displays elevation data, so there must be some change in Strava parsing code.

This is really frustrating. Hope someone will fix it soon!


same thing here, tried both ways, the automatic sync and the manual upload with the 2 option file extensions from iFit, no elevation shows.


plus the default art that iFit post with their workouts is not showing too


this started to happen to me 2 weeks ago I believe 


so many resets and restarts 


It’s working again … the auto sync with Strava gets the elevation now. But not the workout photo… it’s a progress towards a good thing I hope.