Showing results for 
Search instead for 
Did you mean: 

Default Activity When I Go To Record

Mt. Kenya

Greetings! It is not easy to find where to post or where to get help. Hopefully someone has some guidance. I use Strava for cycling probably 95% of the time but one time I went hiking about 3 months ago and decided to record it. 

Now whenever I open the app to record it starts with hiking and no matter how many times I switch it to biking it never stays there on subsequent rides. Any ideas? Fixes? 

Thanks! Also a direct contact to Strava would be nice too. 


The only thing that worked for me was deleting the app and reinstalling it. Immediately, it defaulted to Run, as I had set it to. Worked a treat.

View solution in original post


Mt. Kenya

Is there any way to set the default to e-bike?  I use my Samsung Galaxy watch to track my e-bike rides but it does not distinguish between e-bike and regular bike so all of my activities appear as a ride, rather than an e-bike ride.

Mt. Kenya

Hi.  Is there a way to set the default sport to E Bike ride?  I have to change it manually and it is a pain.


Mt. Kenya

If i wear my Apple Watch I can select any sport. If I forget my watch and have only my phone, I open the app and “Ride” shows and I have no way to change it. I have to edit later. 

Mt. Kenya


why can't I set my default sport to my sport - walking?


I tried the suggestions again, and only a delete/reinstall worked.

Also odd that the web only shows ["cycling", "running"] as Default sport Clipboard01.jpgoptions.

Mt. Kenya

Mine is stuck on gravel ride. My profile default is "cycle". Deleting and reinstalling the phone app did not help. 

Mt. Kenya

I had the same problem, but found a different fix:

I set the Default Activity in Settings > Display Preferences IN MY ONLINE ACCOUNT at (that setting does not appear anywhere on my phone app)

Then I logged in from my phone using the same account and the default activity preference was set properly.

Silly, but worked and maybe a bit more satisfying than deleting and reinstalling the phone app.

Thanks, this fixed it, log out of app then in again after changing default activity on the website settings

This did work - one has to remember to log out of the app and log back in.

The preference is apparently only loaded at login (not pushed/checked) which is why reinstalling works as well of course.