Showing results for 
Search instead for 
Did you mean: 

Strava iOS App Activities Not Showing Images


Seeing a really odd issue over the last few days. All activities in my feed - including my own - are not displaying any images (map, photos) other than video. Everything is fine when I logon via a browser. I have tried logging out and back in again, deleting and reinstalling the app, but nothing seems to be working. I’ve also checked my security settings just in case - no change. Any ideas?


if you have a VPN try try disabling it then open up Strava again.  I’ll list Strava’s reply when I receive it 

View solution in original post


Mt. Kenya

Same issue for me the last week. Tried turning off and on , singing out of app etc but nothing worked. I then noticed there was an iOS update pending and once I had installed that it’s all working again ok showing maps and photos… either a fix for the issue… or coincidence..?! 


Interestingly enough I have seen the issue resolve itself but only for 5 to 10 minutes, then it starts again. Also not seeing thumbnail photos as others have noted.

if you have a VPN try try disabling it then open up Strava again.  I’ll list Strava’s reply when I receive it 

Thanks CRp. I had exactly the same issue. Turned off Norton’ VPN and problem solved. Strange, because it never happened before but now I have a fix if it happens again. Thanks! 👍😊

That’s good Jason.  I find that Norton 360 stops me downloading quite a lot of things.  Glad you got it sorted .  Best Regards. Chris 

Yes same thing happened to me.  No maps or photos uploaded but if I touch the map it loads.  Pics or videos still don’t though.  Been to Valencia and turned Norton 360 VPN on.  Turned it back off agin on my return to UK and issue now resolved.  Lot of googling to try and find out what the problem was until I read this thread!  Thanks!!

I’ve just disabled my VPN (Norton 360) and the issue is sorted. May have to play around with my VPN settings to see if I can resolve when the VPN is on, although I don’t need the VPN on at home.

I’m also using Norton 360. I’ll try and figure out what’s causing it.

Yep, disabling VPN solved the problem! I guess some content is blocked somewhere. What VPN client are you using?