Showing results for 
Search instead for 
Did you mean: 

Apple Watch didn't record Swim distance or save time

Mt. Kenya

Did an indoor pool swim yesterday. Chose the Indoor Swim mode in the Strava app on my Apple Watch and swam ½ a mile. The watch showed the time passing, but never any distance. When the activity was uploaded to Strava, it only uploaded heart rate, no distance, no time. What did I do wrong?


Moderator Moderator

Hi @STL and @danielfc 

Sorry to hear of the issue recording distance.  I'm going to ask both of you to please submit a support ticket and we’ll be happy to investigate further.  Thank you.

Jane (she/her)
STRAVA | Community Hub Team

View solution in original post


Mt. Kenya

Did an outdoor swim today and on watch it never shoes distance just time. When I saved it it didn’t even record time. Very disappointed. 

Mt. Kenya

Same for me with Series 5. Had to use the Apple tracking app. Why is there a swim function in Strava if it doesn’t work?


I also faced the same issue with my apple watch during swimming. Now got a lot of positive recommendations from your comment section. Thanks for posting, I was struggling a bit due to this issue. 

Mt. Kenya

my apple watch 8 when i first bought last year tracked open water swim distances and then a few months ago just stopped tracking distance and only time now. Very Very frustrating

Mine did the same at the start of this year, have checked all updates, deleted and re downloaded the app and it’s still not working. 
did you manage to fix yours? 

Nope very annoying that's for sure

No fix yet, I’m just using the workout app on the Apple Watch. It works for outdoor and pool swims but is very inaccurate, chops about 10% off outdoor distance and typically misses 2 whole laps on a pool swim. I haven’t tried using Strava on a pool swim yet. 

Mt. Kenya

Experienced the same issue today, just wondering if you got a solution?

I had it just happen this morning during my swim. But I also kept adding additional workouts after I got out of the pool (weight training, and a run). So when i completely finished all my workouts I ended it on the Apple Watch Ultra. So then I got home and checked the Strava upload and the swim only loaded duration and calories. So to fix this I deleted the swim import from the strava settings menu, then reloaded it. That fixed the data pull from the watch and is now showing all the metrics strava can use coming from the pool swim workout.