cancel
Showing results for 
Search instead for 
Did you mean: 

Starred Segments not showing on Garmin Edge

Chris_R
Mt. Kenya

Hi guys 'n gals, I really hope you can help me with this one as it is still causing me problems.

There are a number of routes that when I go out and ride the starred segments don't show on my Garmin Edge. I have tried removing them, and then adding them again, but this doesn't help. 

I am able to add new segments which appear like as normal, it's just a lot of my favourite segments I've had from the beginning no longer show -  it's harming my ride experience. 

I  really hope someone has a solution to this problem.

Many thanks in advance of a reply.

Kind regards, Chris.

1 ACCEPTED SOLUTION

Scout
Moderator Moderator
Moderator

👋 @Chris_R@planchee@Velocipede@Bartek
Checking in on this post. If you are still seeing this issue, please submit a support ticket and direct the support ticket to the attention of Jimi. Please include any info you think would be helpful (device model, version, links, screenshots, etc). This will help to further investigate this issue. 


Cheers,
Scout (she/her)
STRAVA | Community Hub Team

View solution in original post

10 REPLIES 10

anchskier
Denali

@Velocipede - For the segments that you are saying don't show up, have they ever shown up as live segments?  Remember that downhill segments (any segment with a net downhill slope) will not show up for live segments.  

Scout
Moderator Moderator
Moderator

👋 @Chris_R@planchee@Velocipede@Bartek
Checking in on this post. If you are still seeing this issue, please submit a support ticket and direct the support ticket to the attention of Jimi. Please include any info you think would be helpful (device model, version, links, screenshots, etc). This will help to further investigate this issue. 


Cheers,
Scout (she/her)
STRAVA | Community Hub Team

Hey Scout, 

thanks for following up!! Considering the winter weather here, I will not be able to test immediately -but will definitely keep devices and account updated and report back to Jimi if relevant 😉 

Cheers,

Bram.

Velocipede
Mt. Kenya

I have had this problem for years on one or two particular segments. I have lots of starred Strava segments that work fine on my Garmin, and I can generally add others. But one or two just won't add. I have tried unstarring, syncing, restarring many times, but no ability to get them to show. Would love other strategies. 

Bartek
Mt. Kenya

Same for me. Unfortunately it doesnt work. Any updates?

planchee
Shkhara

Same issue here.

  1. I create routes on Strava,
  2. star some segments,
  3. star the route (auto-syncs to Edge830)
  4. .. and the segment does not show up while riding. 

Some created routes on Strava also don't contain the starred segments in the 'route details' page either. 

Annoying

It is unfortunately a known issue that some live segments may not appear when following a route on Garmin devices. We recommend unstarring the old segments, resyncing your Garmin to Garmin Connect, then starring them again and resyncing one more time. For more information please see our article on Strava Live Segments on your Garmin. Let me know if this helps!

Seems to work.. some of the times. But then again, could be because it's cumbersome and related to syncing times. 

Still hoping for a better fix, where creating a route and starring segments just works: riding the route and seeing the starred segments pop up 😇

Soren
Denali

Hello @Chris_R -- thanks for posting this question about your starred segments.
Are you consistently not seeing the same (old) starred segments appear in your live segments view or do they occasionally show up?
Garmin devices can hold up to 100 segments. If you have over 100 starred segments, you’ll see what you starred most recently (which explains why the new ones appear as normal).
We recommend unstarring the old segments, resyncing your Garmin to Garmin Connect, then starring them again and resyncing one more time. For more information please see our article on Strava Live Segments on your Garmin. Please let me know if this helps!