cancel
Showing results for 
Search instead for 
Did you mean: 

Strava data not showing in pc browser version

Raz65p
Shkhara

Hello, my data is not showing in pc browser version of Strava. I've searched the problem and saw that many other people have had the same issue and I tried some of the suggested fixes such as clearing cookies. However I have not been able to resolve the problem. I have the problem with Chrome and with Edge so don't think it is browser related. Any suggestions?

1 ACCEPTED SOLUTION

Scout
Moderator Moderator
Moderator

Hey All 👋!

Thanks for writing in. We are aware of this issue where certain areas of strava.com are not loading. We believe this is due to the properties of an ad blocker. We have found that disabling your ad blocker will resolves the issue for some.

Additionally, you can try adding d3nn82uaxijpm6.cloudfront.net to your Adblocker allow list and see if that clears it up.

If you still have issues, please submit a support ticket and we will investigate further.


Cheers,
Scout (she/her)
STRAVA | Community Hub Team

View solution in original post

10 REPLIES 10

Scout
Moderator Moderator
Moderator

Hey All 👋!

Thanks for writing in. We are aware of this issue where certain areas of strava.com are not loading. We believe this is due to the properties of an ad blocker. We have found that disabling your ad blocker will resolves the issue for some.

Additionally, you can try adding d3nn82uaxijpm6.cloudfront.net to your Adblocker allow list and see if that clears it up.

If you still have issues, please submit a support ticket and we will investigate further.


Cheers,
Scout (she/her)
STRAVA | Community Hub Team

nevyoung
Mt. Kenya

I have access again today. Bizarrely coincidental that on the day that I installed the Brave browser, Strava misbehaved! The only suspect had to be the browser - sorry for blaming you Brave. By the way, so far I am very happy with Brave. 

Raz65p
Shkhara

Strava support responded to me suggesting to check for adblocker and try switching off. What I did first was switch off my Bit defender firewall and then tried. Everything loaded normally. I then switched the firewall back on and everything still loads ok so not sure if that was really the problem 🤔. In any case it is working again so I'm happy 😀

It had nothing to do, for sure. When I have read your post, firstly I thought about the adblocker and the likes, but before doing anything, I've tried and now is working, so has to be their issue.

TriSome72
Mt. Kenya

Finding the same problem, cleared cookies and browsing history, nothing, then opened incognito browser, logged in and all data displayed normally... trying to figure out if Bitdefender or any add blocker has anything to do with this...

Same problem, incognito doesn't work, either

Exactly same here. Incognito mode works, normal one, doesn't. Even more, if I copy one activity in incognito mode and paste in normal mode, it works to a certain extent (the drop-down menu button doesn't work, nor the segments info ant the likes, just the summary).

Raz65p
Shkhara

I just tried installing Brave and tried with that. It still doesn't work!

nevyoung
Mt. Kenya

Moved away from Chrome to Brave today. Strava does not display any data - only menu. Chrome still works. Hope you can resolve the issue.