cancel
Showing results for 
Search instead for 
Did you mean: 

[bug] When importing GPX file in strava.com/routes/new, activity is always changed as "cycling"

loicroybon
Shkhara

When importing GPX file in strava.com/routes/new, activity is always changed as "cycling". So when I want to import GPX files for my trails, as they are produced by event organizers, the trace is modified by Strava to follow other ways. That's very problematic to prepare my trails. Does anywone have the same issue ? Any idea to solve it ?

Thanks ! 

8 REPLIES 8

RanHug00
Shkhara

I am having the same problem.  The GPX schema at https://www.topografix.com/GPX/1/1/gpx.xsd indicates there is a <type> element within the <trk> element, but I can't find what values are legal (or Strava compatible).  I tried a wild guess of <type>Run</type> following the <name> element, and Strava seems to have imported the GPX as a Run.  I tried 'Trail Run' but met with another 'Ride'.  I'm not sure how many guesses I want to hazard to get Strava to think its a Trail run.

I observed that Garmin exports trail running courses with <type>trail_running</type>, so I tried that, but import to Strava as a route again produces a 'Ride'.  This morning I reproduced my success at specifying <type>Run</type> and getting a Strava 'Run' route.  From a separate thread https://communityhub.strava.com/t5/developer-discussions/gpx-trk-type/m-p/8482, the moderator suggested https://developers.strava.com/docs/uploads/ as containing the answer, but if it does, I cannot find it.  It may well be the correct reference material but it needs to be updated with this didactic information.

I just did a new test with a GPX file provided by a race organizer. Looking at the contents of the GPX in a text editor, I noticed that no <type> tag existed.
When I import it as is into Strava, the activity assumed by Strava was set to "Bike".
However, when I modify the GPX file by adding the <type>running</type> tag just before the <trkseg> tag, then the "Running" activity is taken into account !

Interesting how either 'Run' or 'running' are both detected by Strava and create a course of type 'Run' instead of 'Bike'. I suppose there is a case to be made that courses are created for cycling more often than they are created for runs of any type and thus defaulting to 'Bike' is logical.  All we need is to know what else it is looking for!

For me the best solution could be to ask user for activity type on each GPX upload. Sometimes, GPX can contains an activty type different that the activity that we we want to do. Sometimes, GPX does not specifies activity type and define a default value is not pertinent for all users. 
Fatmap (now part of Strava) works like this : 1.Define activity type, 2.Upload GPX or draw on map. 

Thank you for your message, it is very interesting to see that we have tested the same things. I also couldn't find a value that would make this import work again. Before, everything was working fine for me. I feel like a recent update in the course editor broke this import.
Attention Strava Developers: Please read this thread and provide a fix!

[subsequently deleted]

loicroybon
Shkhara

Any suggestion please ?

Ready, Get Set, Go!

Welcome to the Community - here is your guide to help you get started!


Know how to use Community


Understand Community Settings