Showing results for 
Search instead for 
Did you mean: 

Activities not syncing

Mt. Kenya

My Apple Watch has stopped syncing workouts. It was fine then only synced a piece of a workout (no map only distance data) and since then nothing. When I save it, it says uploaded, but it doesn’t appear in my workouts. I have tried everything and many emails from help, but they just keep getting closed and nothing gets done. It is really frustrating and I didn’t change any settings it just doesn’t work anymore. Anyone else having similar issues, or suggestions. I also uploaded some pictures recently, but they aren’t in my workout, but appeared in my mates. Surely there is a data issue here. Like I say Strava help and Twitter haven’t responded, maybe Strava community will know what to do. Thanks


Moderator Moderator


Thanks to everyone who posted about this and so sorry to hear about activities not syncing.  

Can you please try the following:

Force quit both the Strava watch app and the app on your mobile device.  

Press and hold the side button until the shutdown screen appears, and then press and hold the digital crown until the app closes. You must be in the app to force it to close.

Please let me know if that resolve the syncing issue.

Jane (she/her)
STRAVA | Community Hub Team

View solution in original post


Mt. Kenya

I had ongoing sync issues between my iPhone and my Apple Watch. After trying most of the suggestions in this thread, I wanted to add a couple more things that others can try:

  1. Reboot both your Apple Watch and your iPhone; and
  2. Reboot (restart) your router.

Basic stuff, but you'd be surprised how long it took me to try it. I was ready to move to another app when I was able to achieve peace and happiness through restarting my devices! Namaste!

- David

Mt. Kenya

This happened to me after changing the email address on my Strava acct. Tried suggestions here to no avail. Logging out & closing the app on my phone & watch then opening it & logging in again worked for me. 

Mt. Kenya

I was having the same issue and was growing frustrated that my workouts were not being uploaded. I force quit both the app on my phone and the app on my watch along with restarting them both with no luck. 

What I stumbled on was checking the devices connected and saw that my Apple watch somehow got disconnected. to reconnect it just open the app on your phone, go to you, then click the gear icon (settings) and select Applications, Services, and Devices. Here you can re-add your Apple watch. Once re-added, I was able to upload my activities again.

Mt. Kenya

I solved my sync problems by going to IOs settings and under ‘Health’ > Strava > Turn on all . This allows strava to access your health and import data to strava 

Mt. Kenya

I had unsynched activities on my Apple Watch so I did all the standard fixes restarted Watch and iPhone several times force quit apps all no go

Found cause: I use NordVPN and a few days ago I activated the ‘dark web monitor’ (just to see what it does/did) and this tied in with the time the ‘synching’ stop — so I stopped the dark web monitoring within the NordVPN client and all working again! Yah!

Thanks. I wasn’t using a vpn at the time. I gave up in the end and uninstalled the app on my watch then reinstalled. That fixed it but I lost a few workouts which was a tad annoying. 

Mt. Kenya

Same problem for me. Apple Watch Strava shows no open activities to sync. However, my Strava App on iPhone does not show any activities.

Additional information, I have changed my Strava account on iPhone like last week. Maybe that can also cause an issue? 

Please let me know!

I couldn’t fix it. In the end I had to uninstall the app on my watch then reinstall. It did fix it but it was a pain and I lost some workouts. 

This same issue began for me as soon as I performed a "reset password" and established a new password for my account. I believe it had previously been associated with a Google login. I did this because I began logging into Strava from a desktop browser, as well as my iPhone and Apple Watch, which I'd not ever really done before. 

But as soon as I made that switch in the morning, I went out and did a run, and now I can't for the life of my to get the activity to sync from the watch. I get the message "To sync your activity, make sure your Apple Watch is connected to the network." (it is) - When I click the "Synch" button on that screen it just goes right back to the "Unsynced" page with the run still on it, not uploaded. 

I've tried the "force quit apps" on both the watch and my iPhone, and I've also power cycled both devices. Neither trick works. Same result: Activity will not sync.

This is seriously making me consider going back to my crappy (but reliable) old Garmin watch.