Showing results for 
Search instead for 
Did you mean: 

Internal Server Error on at first boot of app on samsung watch

Mt. Kenya


I have reinstalled my Strava app on my Samsung Gear Sport AB91 SM-R600 .

This because I got a new non-Samsung cell phone and Samsung forced me to reinstall it Strava App on Watch. Tizen OS  4.0.0 7 Knox 2.3.1 TIMZ 3.0.0

At first boot of the Strava  app (1.7.24) I see that I need to type in 4 digits, for authentication.
On my mobile phone ( having connected the Samsung Galaxy Wearble App) the app redirected to 

which shows:

{"message": "Internal server error"}

Why is this msg seen?
Also is there anywhere else I can get those 4 digits from ? ( from another than the web site that respond HTTP500) .
So that I can continue to use Strava on my Samsung Watch Gear.

I have no problem with any other Samsung apps*  on my cell phone, nor on my Gear Watch.
I only have problem with the Strava app, on the Gear Watch.

*(nor account problems after creating a password - because there were none initially as it was created on google initially)

Thanks for any ideas,
Usain Bolt



I had this problem on My Samsung Galaxy S3 Frontier.  I had to reboot the watch after installing the strava app on it. Then the 4 digit code finally worked.


Looks like everyone is now reconnected, or people who have not, please try .

I took mine off my Samsung equipment and re-installed, All seems OK, however, not yet tested.

And hand on heart, I had tried other simular to Strava, but far too much pxss balling around, especially when running and your hands are wet, and hahah, if like me blind as a bat, really couldnd see ehat i was to be doing.

Anyways, PANIC OVER! I guess, things happen...... I wonder what we all did before all this techno stuff!! (showing my old age now) 

Mt. Kenya

Mine is working again... Big let down by Strava, lost 3 activities but entered manually. Happy it's fixed now...

Happy exercising everyone ✌️

Mt. Kenya


Just reconnected myself after deleting. Lost one activity. Glad it's fixed. Marathon on Sunday 


Mt. Kenya

I also receive a code. But still not working. On the watch i see "connecting" and after a few moments "Time out".

Deleting the app and downloading again did the trick. Connected again! 


Happy days, I am now connected.

Mt. Kenya

Ditto this has been happening since Tuesday, Oct 10. Why is the website also down to get a new code.

Mt. Kenya

I've got the same problem, i cannot sync my activities... Help !

Mt. Kenya

Same problem here