Showing results for 
Search instead for 
Did you mean: 

Android 13, Strava app version 351.18 (1234809) GPS recording issues (walk/hike)


Good morning to everyone.

I have a problem with Strava app and I want to ask if anyone else has the same issues.

I have two smartphones:

Redmi Note 9 Pro, Android 12, Strava app version 351.18 (1234809) and

Realme 10 (RMX3630), realme UI 4.0 /Android 13, Strava app version 351.18 (1234809).

On the Android 12 phone which I used in the past 2+ years, all recordings are accurate.

On the Android 13 phone though, my cycling recordings are correct but my hiking/walking activities are almost 20% longer than normal. Looking at the activity map, I can see that I am walking in small loops (like a drunk person) and there are no straight lines between points which would indicate a gps signal loss. I have tried with or without connecting sensors (in-app choice when you start an activity and press the cog), battery optimization is disabled for Strava (the app has full authority to use all the resources and restart itself automatically and no "sleep" mode either). I have enabled the "use precise location" option and I have also unchecked the auto-pause for the run/walk/hiking activities. I have restarted the A-GPS data with the GPS status app, I have installed and uinstalled the strava app three or four times and eventually yesterday I did a factory reset to the Android 13 phone. To no success!!

My final try was to install Sports Tracker, give it the same rights (access to sensors, full battery use etc) and testing it on the same 1km route for six times and all of them are accurate!!!

The only difference I have managed to find between the two apps is that Sports Tracker has an option in Location permissions that says "Allow all the time" and Strava only has an option saying "Allow only while using the app".

I am sorry for the extremely long post but I wanted to document all the steps I did before posting it.

Any ideas?

Thank you


Mt. Kenya

Recent update broke everything. Shows my live lication on Strava map  and moves but no path tracked and 0 speed. Samsung health has gps fine. Strava on Galaxy watch has exactly same issue, reports gps success and does nothing. It seems to be intermittent after uninstall and reinstall and playing with permissions. Did they hotfix something?  Not good enough Strava. You broke core functionality.


My Google Pixel 7a currently has Android 13 and the GPS track for running activities from STRAVA is terribly erratic as well.  I sometimes use the app to record a run for my dog separately from my Garmin watch (for myself).  My dog's distance is inevitably .2 miles longer because of all the jagged tracks recorded by STRAVA and as a result, her pace will be several seconds (if not tens of seconds) faster than me, despite being literally tied to my waist.  An external fitness tracker with dedicated GPS is going to be your answer for accurate metrics.

Thank you MattgS_bsb for your input.

Eventually I ended up using Sports Tracker for hiking/walking and Strava for cycling and all is well


Jane thank you for your answer.

I've tried the steps you proposed in your answer but unfortunately without success. The thing is that recording a cycling activity gives me an accurate distance/time/speed and only in hiking/walking I get the weird results (small loops appear in the activity instead of walking straight). Another fitness app works fine in all tried activities.

The only thing I found to be different between the apps is that the other app has an option in Location permissions that says "Allow all the time" and Strava only has an option saying "Allow only while using the app".

Moderator Moderator

Hello @vasgko2 

Thanks for posting about this.  It sounds like your Android 13 phone is not recording GPS accurately when using the Strava App.  

Can you first try turning your phone completely off/on and then flipping location services off/on? Before your next activity, wait several minutes with a clear view of the sky so your phone can get a strong connection.

If that doesn't help improve your recordings, this may be caused by certain Android settings. There are a few possible culprits and some of them are unique to the make/model of Android, so please check the following:

  • Find your phone's location settings and make sure that you are using the option that allows for the best GPS performance/accuracy.
  • Find and disable your phone's battery saver settings. These are typically located in Settings > Battery > Battery Saver.
  • If your phone has a battery management mode, please turn it to "off" instead of "medium" or "high".

Please let me know if you continue having trouble after giving these steps a try.

Jane (she/her)
STRAVA | Community Hub Team

Hi Jane

What you have outlined is the general troubleshooting steps? That doesn't solve the issues. I am having the exact same issues and it's happening only for runs. While Android has updated, looks like strava app hasn't kept up to date. Even leaving the app open all the time while running, the location goes wayward. I can see location symbol ON all the time. It just drifts away. Location permissions that says "Allow all the time" is not available anymore in Strava and only has an option saying "Allow only while using the app". Could that be the main issue? I have been using Strava for runs and other activities for so long but it only started the issues in the last few months.

Can this be looked at in detail?