Showing results for 
Search instead for 
Did you mean: 
This post has been escalated to our Support team for one of the following reasons: it requires sharing personal information, the intervention of an admin, or multiple exchanges. We may also escalate to our Support team if a topic is highly complex or technical.

Apple Fitness workouts not shown in Strava

Mt. Kenya

Since end of November, Apple Fitness workouts are not shown anymore in Strava.

I double checked the permissions, relogged int Strava, resetted permissions, it just doesn't work anymore.

I can see the workouts in my history and can also try to reuplad, but they are not shown anymore since end of november.

Latest versions of iOS (17.2) and Strava are installed on my iPhone. Any suggestions?


Moderator Moderator

Hello @tiemun 

Thanks for your reply.  Can you confirm how you are recording these workouts?  For example, are you using the Apple Workout App or using some other method?

Also, please check and confirm the following setting:

Settings iOS app > Health > Data Access & Devices > Strava (Please make sure that Strava has access to read/write Workout Routes)

Thanks for your patience.

Jane (she/her)
STRAVA | Community Hub Team

I am using the Apple Workout App with Fitness+, exactly.

I can confirm all points are enabled for accessing Strava.


Is it possible it is an issue with the workouts itself to import to Strava? And I just cannot see the error message from user perspective?

Hi @tiemun 

Thanks for letting me know.  I'm going to escalate this ticket to Strava Support so someone can take a look at your account and troubleshoot with you directly.  

Jane (she/her)
STRAVA | Community Hub Team

Moderator Moderator

Hello @tiemun 

Thanks for posting that and sorry to hear that's happening.  In regards to the missing workouts, can you confirm you're recording them with the Apple Workout App and not syncing them into Apple from a third party device or App?

Please be aware that only activities recorded with the Apple Watch Workout app recorded within the past 30 days are able to sync to Strava. Activities uploaded to the Health app from a third party will not sync to Strava.

If these are activities recorded with the Apple App, please doublecheck your settings:

  • Navigate to Settings  > Applications, Services, and Devices > Health > toggle Automatic Uploads ON 

If this is already set to "on".  Try toggling it on, then off again.

Let us know if that solves the issue.

Jane (she/her)
STRAVA | Community Hub Team

 Hi Jane,

I already tried that and can confirm settings are correct. 
Also tried reinstalling, etc. 

Weird is, it worked fine until end of November. You may see that last upload was on 28th. Nothing changed (except updates on iOS and Strava)