Showing results for 
Search instead for 
Did you mean: 

Garmin Connect activity upload problem.


Having a problem with route uploads from my Garmin GPSMap 66st to my Strava account via the Garmin Connect app.

For a while now, all it will upload is the very first part of the activity. Distance is showing as a few metres regardless of activity length. However, the calories burned figure tallies with the Garmin record.

I've seen that there are some issues recently with syncing, but this has been happening to me for a good while now. I've not yet tried a file upload direct as yet. 

Any ideas?  Is it likely to be a Garmin issue or Strava?

Attached are screenshots of the Garmin Connect route and what Strava shows of the same.




Mount Logan

I don't have a good answer for you but there are a few things I would recommend trying to narrow down where the issue is. You'll want to do this on a laptop/tablet since many of these features aren't available in the mobile apps.

First, download the original activity file from Garmin Connect (click in to the activity in Garmin Connect and click the gear in the upper right corner. Select "Export Original").

  1. As an initial check, manually upload the activity file to Strava ( You may need to delete the original activity from Strava since it detects duplicates. If it uploads the entire track as expected, the issue is in the Garmin->Strava connection, you'll need to contact Strava support. In the meantime you've got a workaround which is to download the files and manually upload them. My guess is that this won't actually work, but it's worth trying.
  2. Try loading the file into a viewer like If it shows up correctly, the issue is possibly/probably on Strava's end for how the file is processed. Otherwise the issue is probably related to how Garmin saves data into the file.

If after the above two it ends up being how Garmin saves data to the file, another thing you can try is to download the data in a different format. The same way you downloaded the original file from Garmin Connect, try exporting in one of the other formats like GPX. Then repeat steps 1 & 2 and see if things are better. Again if that works it's more of a workaround than a solution, but it at least gives some extra useful information to help understand what the problem is. If it doesn't work then there really is a problem with how the data is recorded and it's on Garmin's end.

Just as an addendum to my first reply, the file received by Strava is a .fit file. My Garmin is recording both .gpx and .fit. I'll have a look through the settings to see if there's an option to alter what is synced with Strava and see if it makes any difference.

I don't have much more advice to offer based on what you've said. But at least now you have some data to give to support to help figure out the problem. To my knowledge there's no way to change what is synced from Garmin to any 3rd party, there's just a toggle switch to enable/disable activity sharing.

One more interesting thing to test would be downloading the .fit file from the Strava activity then trying to manually upload it. That would tell you if the file Strava received has an issue, or if it's some sort of processing issue.

Just a quick update on things I've tried so far...

Gave the download of the .fit file from Strava a go. File remains the same when uploaded again, so it appears Strava processing is fine.

I've had a look back through my activities over the past year or so. There seems to be no consistency with regard to how the faulty uploads manifest themselves. If I'm tagged for the same activity by another user and upload my own Garmin record, it mostly works fine but sometimes doesn't. Same if I've used both my Garmin and the Strava app for the same activity (with or without being tagged), the uploaded activity sometimes corrupts but mostly doesn't. Same thing if I just use the Garmin upload without the Strava app.

Just for info, if I try to upload the original Garmin file (confirmed as ok) without deleting the faulty Garmin Connect upload, Strava gives me the duplicate activity message, even though file size etc is totally different. Wondering what data it uses to assume a duplicate? Just file time and date? Start location (which always shows correctly, even in the faulty uploads)?

The only other thing that springs to mind, is if I try to upload my Garmin file via the Connect app and my mobile signal is weak, would this effect the outcome, maybe some data corruption? Would've thought there'd be some form of data verification though. I need to try a few experiments with uploading out in the field with a poor signal and then the same on a good wifi signal.

Not yet contacted Strava support, until I've got some consistencies.

Just a little update... I've just done a short walk of a few miles and then uploaded when on full strength wifi.

The upload to Garmin Connect is fine, but the further upload to Strava has the shortened route problem again. Again some of the data is correct, such as calories burned and height gained.

Looking at the Strava result shows the chequered flag finish marker at a point where I knew I had stopped for about 5 minutes during the walk. This was the first time I'd stopped on the route.

Looking at my Garmin device settings, it has an "auto pause" option to reduce file size/saved waypoints when doing nothing. I wondering now if this is the cause of the problem. It was set to "auto" with regard to time and distance and a 1 mph speed. Could this put a marker on the track that Strava then interprets as a finish point maybe? 

Next test is to do another walk with the setting altered to distance only waypoints and no auto pause... I will post a further update in due course!

Thanks ActivityFix, seems my thread has been hijacked.

I've now had chance to try some things, now I've got some free time. I've tried a manual upload with both .gpx and .fit files, just for the route in my op for the time being, and they both upload perfectly - route display and other data.

So, you're thinking this maybe a Garmin to Strava connection issue? I'll contact Strava support for further suggestions and come back to this thread.

Thanks for your time, so far.

Thanks for the suggestion. I was already aware of this solution.

It just annoys me that this automatic sync from Garmin Connect towards Strava is not working correctly.

Which solution works? I'm curious as to where the problem is exactly.

When I just download the track as gpx from the Garmin Connect webpage and upload it to the Strava webpage everything is ok.

But the automatic sync from Garmin Connect to Strava fails: It just uploads the first part of the track until the first break in my trip.