Showing results for 
Search instead for 
Did you mean: 

(RESOLVED) Error message (non-null is null) when attempting to sync activities on Wear OS app

Former Member
Not applicable

Sync of walk between Galaxy Watch 4 (Wear OS) and Samsung S21 failed. Fresh installs on both the phone and watch.



Moderator Moderator

Hi All 👋!
Thanks for your patience and sorry about the issues.

You can try the steps @TheFostah noted which resolved the issue without losing any data:

Open Strava on watch, sign out, and sign back in and it should ask you to grant it permission again.

If this doesn't work for you, our team has pushed a fix and you will need to do the following:

1. delete the Strava application from your watch
2. Power your device off for 10 seconds
3. turn your watch back on and reinstall the Strava application (v1.39).

Unfortunately, this will discard any pending activities that have not yet synced to your account but will remove the error and new activities should sync over again. If you have issues after doing the above, 
please submit a support ticket. If you have trouble with our online form, you can send an email to Please direct your email to the attention of Jimi. 

Scout (she/her)
STRAVA | Community Hub Team

View solution in original post

136 REPLIES 136

Am also getting the same error 

Got sync this morning 


Sometimes it works and now last 2 days again no sync. 

There was an update in the google store but didn't solve the issue

Mt. Kenya

+1 here now. Synced fine on Monday after run - now roll on to Wednesday it's not syncing at all. Is this bug getting fixed sometime as it's widespread?


I get the error on the Pixel Watch 2 (Strava App version 1.39, build 78101). The exact error message is this: 

Parameter specified as non-null is null: method yb.e.apply, para... [can't read the rest]

Mt. Kenya

Same issue with Samsung watch 6 & Asus zenfone 8. I have 2 activates backed up both showing the same error. I have reset both phone and watch to no effect.  

Mt. Kenya


Hi, i solved the issue! 

Using samsung galaxy watch with samsung galaxy s22. I couldn't have resynced.

1. Try to restart both phone and your watch, and the error should dissalear.

2. Then wait overnight and resync - it should.

3. Uninstall application from both if your devices and reinstall them.

4. Resyncing shoukd work now right away.


(if you uninstall without syncing you will loose data. Thats why I'd try steps 1-2, before reinstalling)

I hope it will work for you! 

Mt. Kenya

Same problem here with Samsung Galaxy Watch 6 and Samsung Galaxy S22...

Mt. Kenya

Same issue here, I got the Null-parameter erro message and was unable to sync my run with the app. Pressing the sync button didn't do anything. Restarting the app, watch and smartphone app didn't do anything too. Got it resolved this morning by disabling the bluetooth on my phone en enabling it again.

Galaxy Watch 4 44mm and Pixel 6, both running all the latest updates

Mt. Kenya

After a race, I got the same error. It was so frustrating because I PR and I couldn't see the full stats. After 8 hours, I hit the unsynced on the Strava app on the watch, it finally synced. 

Ready, Get Set, Go!

Welcome to the Community - here is your guide to help you get started!

Know how to use Community

Understand Community Settings