Showing results for 
Search instead for 
Did you mean: 

It looks like you're using a browser that Strava no longer supports.

Mt. Kenya

Hi, i have problems with my strava on PC/Web.. 

it always fails to display the page perfectly in the last 5 days, I've tried using chrome, incognito, and firefox all of them can't display it. One of the info on the page says: "It looks like you're using a browser that Strava no longer supports." I've checked my chrome version, it's the latest version.
is there anyone who can help me?


123 Im back in the room lol............FIXED IT.........Turned of my Norton VPN setting......and STRAVA was back to Normal , Turned VPN back on in Norton and its still working..........Give it a try

View solution in original post


I don't know why Strava is not addressing this issue. I haven't been able to load the Strava dashboard on my Google Chrome for the past several months. I know Strava is aware of this issue. Now I basically just keep a Strava tab open on Firefox and use FF for all my Strava stuff. Still use Chrome for everything else. 

I'm not using VPN, but having this issue with Chrome for a while now.

My problem is only on .

Im on Firefox and cleaning cookies for seems to solve the problem.

I have the exact same problem for the last 2 or 3 days, only on, initially loads the activities and then clears everything, if I refresh the page 2or 3 times eventually it gets right. I don't use any VPN, at least not the conventionals for "privacy", I do use VPN's to connect to office sites.

Started having the same issue 2 or 3 days ago on a Windows 11 computer with Chrome, both up to date, with or without VPN, with or without extensions.  No issues on the same setup on another computer and on a Chromebook.  Very strange...

And today it is working fine, no changes at my end. 🤷‍♂️

And... the problem returned a few days ago for me in Chrome.  Now I just keep Strava open in Firefox until it works again in Chrome. 😂

my problem is exactly the same

Hello Jane, this is Geoff in Belgium. 

I'm having the same problem, that is all the text is there, but the cascading stylesheets would seem to be not uploading. 

I'm using Chrome, Windows 11. My wife has a new laptop, same apps, and Strava works perfectly. 

Thank you for your help.