Showing results for 
Search instead for 
Did you mean: 

Strava on Galaxy watch 5 pro



I have just purchased a new Galaxy watch 5.  I have tried using the Strava app on the watch when i bike to work. It seems to record this ok, but when i look at the ride on my phone or website it does not show the time taken. If i go into the ride, it seems to be recording the segments ok.  I tried the walking profile and this worked ok and displayed all the info correctly. Anyone else seen this issue ?



Moderator Moderator

Hello @Carterdj 

Thanks for posting about this and sorry to hear of the difficulty.  This is a known issue that sometimes happens on Wear OS 3 devices.  We do have a workaround that should resolve the time data issue on the activity:

  • Go to your activity page on the website (this feature is currently not accessible in our mobile apps)
  • From the activity page click on (◦◦◦) the more options menu > Correct Distance.
  • From the pop-up, click "Correct Distance".
  • When the status changes from "Calculating" to "Updated," refresh the page.

Please give that a try and let me know the results.

Jane (she/her)
STRAVA | Community Hub Team

View solution in original post


Moderator Moderator


Thanks to everyone who posted about this issue on Wear OS device recordings.  Good news - the problem is resolved with the latest version of the Wear OS 3 App Strava App.  Please ensure you device is updated and thanks very much for your patience.

Jane (she/her)
STRAVA | Community Hub Team

Mt. Kenya

I figured out it happens when the auto-pause activated before you finish your activity. When auto-pause activates, it records your pause time, so the time jumps to 0:00. When you finish your activity at that point, it fails to record it properly and you have to do the fix as mentioned by Jane.

When you are quick enough to finish the activity before the auto-pause kicks in, you are fine.

I hope this info helps the developers at Strava to fix the issue.


that sounds like a very good finding. I will try to deactivate auto-pause on my watch and will report if I have the same outcome.

Hi again,

switching off the auto-pause in the app settings on the watch solved the issue for me, thanks again @remartens


Hi Guys,

this case has been created already in February. 5 months the problem still persists with all permissions given to the watch and the app. Are you in touch with Samsung about this or is not related to the watch itself?

Best regards


Mt. Kenya

I've the same issue. It never used to do this. I only upgraded to a WearOS 3 for Strava, and now find it doesn't work properly on this platform. Very disappointed. 

Mt. Kenya

For some reason my time is not recording for my rides this year. Never had this issue before, but so far it is consistently not recording now that I am out after winter. It records speed, distance, MPH, heart rate. Seems like everything but the time. I tried to uninstall and reinstall on my watch, and that did not solve the problem.

if you go to strava on the web portal and split the ride to 0 seconds times are there.

it is very frustrating

yes, that worked, but hopefully there will be a fix soon so i don't need to do this for every ride too long.