Showing results for 
Search instead for 
Did you mean: 

Wrong activity duration on import from Apple Fitness


In the last couple of weeks I've noticed a problem with run data imported to Strava from Apple Fitness. Strava reports the distance correctly, but the time – both elapsed and moving – is too short, so the pace quoted by Strava is too fast.

It's not the same as this issue previously reported by @Jeroentje, because I don't believe it relates to the difference between total time and moving time. Instead, I think the import process is breaking off prematurely, before Strava has received all the data.

An example: my last run as recorded by Apple was 4.88 km in a total of 31:40 minutes. The average pace shows as 6:29/km, which I know is about right. My Apple Watch has auto-pause turned on, but I didn't stop and didn't pause manually. So I'd expect the total and moving times to be very close.

Following import, Strava agrees on the distance and the GPS track, but says the elapsed time was 27:38 and the moving time was 27:26. I can well believe a difference of 12s, but not the difference between Strava's 27:38 and Apple's 31:40. Strava then calculated the average pace as 5:37 – the math is correct but that was absolutely not the pace I ran.

On looking closely at the Strava pace graph, I see it ends at 4.3 km. So I've lost 0.58 km of distance, which would neatly account for the "missing" four minutes.

The Strava pace graph clearly shows the points where I walked, and on moving the slider, the instantaneous pace readings are all correct as far as I can judge.

So the problem doesn't relate to total time versus moving time. Instead, the Strava import seems to have cut off four minutes (and 0.58 km) before the end of the run – but the total distance quoted in the headline figures is correct, presumably because it's coming from a different field in the Apple data.

Does this narrative make sense, and has anyone else seen anything similar?


@Jane, thanks very much for taking the time to look at this. On three subsequent activities (two runs and a walk) I've not seen the problem again. I have proof that it happened twice, but it seems to have stopped now, so I'll mark this thread as solved. 

View solution in original post


Mt. Kenya

I have the same issue with all of my runs..

Mt. Kenya

Experiencing the same problem all the time. My pace is faster when I import my running data from Apple Watch. I record my run using fitness app on Apple Watch and while my distance is the same for both, the time is shorter on Strava app after importing.


Hi Jane

Thanks. I currently have Strava 343.0.0, updated on 25 January. The second of the two runs showing this problem was yesterday (29 Jan), so it would have been imported using 343.0.0. The first one was on 22 Jan, so I guess that would have been 342.8 if that was the previous version.

I wonder if this is an issue with iOS 17.3, which was released on 22 Jan – the same day as my first run showing an import problem. I can't remember when I updated from 17.2.1 to 17.3, but it's very likely to have been on 22 Jan – I was looking out for 17.3, because it fixed an important security issue.

It doesn't happen every time, because my run on 25 Jan imported just fine, as it always has before.

I'll report back if and when I see it again.

Hi @chazzo 

Thanks very much for the follow-up.  Please do report back if it happens again, we would appreciate that.

Jane (she/her)
STRAVA | Community Hub Team

I experienced exactly the same problem two days ago. My Apple Watch started my run correctly at 8;06. Strava recorded it as starting at 8:11. The other data was correct except the pace, which was faster than in actuality.  Also it didn’t indicate any PR information along the way. 

That’s interesting. It’s kind of the opposite way round to what I saw. My imported activities started at the right time but finished too soon, whereas yours started too late (and finished at the correct time?) 

@Jane, thanks very much for taking the time to look at this. On three subsequent activities (two runs and a walk) I've not seen the problem again. I have proof that it happened twice, but it seems to have stopped now, so I'll mark this thread as solved. 

Moderator Moderator

Hello @chazzo 

Sorry to hear about these issues.  

Can you please make sure your Strava app is running the current version: 342.8
Apple App Store:
Strava: Run, Ride, Swim
How to update your apps on Apple: Support - Apple
Once confirmed, please try recording a new activity and see if the problem recurs.

Let us know if the issue persists after that.

Jane (she/her)
STRAVA | Community Hub Team

@Jane I am currently experiencing the same problem as @chazzo was. Please could you confirm a solution? If the solution is to update the app, please could you let me know what the version should be? Thanks!