Showing results for 
Search instead for 
Did you mean: 

Moving time Apple workout not correct



I thanks since a few weeks strava doesn’t update the Moving time After sync workout.

i use the Apple Watch and the workout running app to record my runs. When i’m done, i open the strava app and sync the workout. After few seconds the run is on strava.

in the past, strava analyses the run and updates the Moving time. So stopping formtraffic light was deleted 

 but now my avg speed etc is worse and i cannot compare my progress.  

‘is this a setting i can change myself?

mny thanks in advanced



Moderator Moderator

Hello @Jeroentje 

Thanks for posting about this.  I'm a little confused about what's happening.  Are you saying that the moving time you see on Strava after your activity syncs seems incorrect, because we are not removing your stopped / paused time?

Thanks so much for clarifying this.


Jane (she/her)
STRAVA | Community Hub Team

moving time and total time are the same.  previous stopping for a trafic light was removed.  this is not working now.

it works fine when i sync a cycling activity. but for running it is still not working

many thanks in advanced


Even when I don’t pause a workout, the wrong amount of moving time shows up in Strava. It’s correct on my Apple Watch, but I’m Strava it’s much lower than what it actually is.

Hi Jane,

all of a sudden have the same issue. Worked all fine until Monday. Same watch and phone since April. 
I’ve tried every GPS reset and location services reset and all sorts. No luck. I have NEVER manually paused any workout. 
it’s like Strava or Apple suddenly can’t see the stationary time. What is even more weird is that the splits and segments are still accurately recorded and match my fellow runners but the average pace is just reflected as weird.
I agree with others- it’s very hard to train speed work or long distance if you don’t really know how fast one is running. 

Yeah that’s exactly the same issue. Was working totally fine now something is not recognising any stops in my run. Still not resolved and was basically told it’s a bug they’re working on. So nothing can be done. 

Mine was also doing this (I replied in this thread elsewhere) but has started working (my moving and elapsed are now different) over the last week. I've never paused a run or walk. Not sure why but hopefully it continues to do so.


Moving time and Total workout time are the same If you use the Apple Watch running workout and sync this with strava app on iPhone.

I am having the same issue. I’ve always ran using apple fitness which syncs with strava. I don’t manually pause but usually when synced strava has the moving time with any stops at roads etc removed and the elapsed time. However, recently they are both the same when I’ve definitely stopped for periods, sometimes of 1 min plus. Any updates on solutions to this? Thanks