cancel
Showing results for 
Search instead for 
Did you mean: 

Only some of my uphill Strava Live Segments are downloaded to Garmin Edge 830

celinedion
Mt. Kenya

Hi, I have some starred segments that are uphill average grade (have goals and everything), but for some reason they don't download to my Edge 830 after sync. I want to emphasize that I do see some live segments on my Garmin (about 4 out of the 10 eligible) but these ones don't download. I've tried unstarring them/syncing/re-starring but that doesn't work - I don't see them in my Live Segments collection

Would love some help fixing this - thanks!

1 ACCEPTED SOLUTION

Jane
Moderator Moderator
Moderator

Hello @celinedion 

Thanks for posting about this and sorry to hear of the issue.  Un-starring and re-starring the segments is a good step; unfortunately it sounds like that didn't solve the problem.

Another thing to keep in mind is that there's a limit of 100 live segments on Garmin devices - if you're only seeing 4 segments, it sounds like that's not the problem either.

You also want to make sure you're using Strava segments and not Garmin segments on Garmin Connect. Read the FAQ here.

Another thing to try is delete all the live segments off your Garmin and try syncing everything again.

Let me know if any of this helps!


Jane (she/her)
STRAVA | Community Hub Team

View solution in original post

2 REPLIES 2

bigair
Mt. Kenya

Been using Strava segments for years. Now they just wont show up at all. Getting a Hammerhead Karu

Jane
Moderator Moderator
Moderator

Hello @celinedion 

Thanks for posting about this and sorry to hear of the issue.  Un-starring and re-starring the segments is a good step; unfortunately it sounds like that didn't solve the problem.

Another thing to keep in mind is that there's a limit of 100 live segments on Garmin devices - if you're only seeing 4 segments, it sounds like that's not the problem either.

You also want to make sure you're using Strava segments and not Garmin segments on Garmin Connect. Read the FAQ here.

Another thing to try is delete all the live segments off your Garmin and try syncing everything again.

Let me know if any of this helps!


Jane (she/her)
STRAVA | Community Hub Team